Accessing a remote gpsd from local gpsd

Discussion in 'General GPS Discussion' started by Nilan, Apr 28, 2016.

  1. Nilan

    Nilan

    Joined:
    Apr 28, 2016
    Messages:
    1
    Likes Received:
    0
    Hi

    (Here LinuxPC_1 and LinuxPC_2 are two prototype boards running Linux)

    Im running gpsd 3.16 in LinuxPC_1 and my UBlock GNSS evaluation kit is connected to thesame LinuxPC_1.
    I start gpsd as follows
    /usr/sbin/gpsd -S 6437 -G /dev/ttyACM0
    It runs without a problem and and if I use gpspipe or gpsmon client tools in same LinuxPC_1, I can see data from my UBlock GNSS.

    Even further, If I run gpspipe in another remote machine(LinuxPC_2) gpspipe -r IPoFLinuxPC_1:6437, I can see GNSS data from my LinuxPC_2 as well.

    Then I want to run gpsd in my LinuxPC_2 and get its data feed from LinuxPC_1 gpsd.
    I run gpsd in my LinuxPC_2 as follows,
    /usr/sbin/gpsd -G -n tcp://LinuxPC_1:6437 (I tried tcp:// gpsd:// both)

    Here are the problems I am facing,

    When Im using gpsd version 3.16 on both LinuxPC_1 and LinuxPC_2 :
    --------------------------------------------------------------------------------------------------------
    I run /usr/sbin/gpsd -G -n tcp://LinuxPC_1:6437 command from my LinuxPC_2, and it can connect to LinuxPC_1 gpsd without a problem.
    Connection is successfull, But if i run gpspipe -r from LinuxPC_2 it gives me,
    {"class":"ERROR","message":"Unrecognized request ''"} error responce.


    When I am running a different gpsd version (3.10 or 2.92) in my LinuxPC_2
    ----------------------------------------------------------------------------------------------------------------
    I run same command, /usr/sbin/gpsd -G -n tcp://LinuxPC_1:6437 then it cannot connect to LinuxPC_1 gpsd.
    It gives me following errors,

    [[email protected] ~]$ /usr/sbin/gpsd -G -n -N -D8 tcp://XXXXXXX:6437
    gpsd:INFO: launching (Version 3.11~dev)
    gpsd:IO: opening IPv4 socket
    gpsd:SPIN: passivesock_af() -> 3
    gpsd:IO: opening IPv6 socket
    gpsd:SPIN: passivesock_af() -> 4
    gpsd:INFO: listening on port gpsd
    gpsd:pROG: NTPD shmat(4325417,0,0) succeeded, segment 2
    gpsd:pROG: NTPD shmat(4358186,0,0) succeeded, segment 3
    gpsd:pROG: successfully connected to the DBUS system bus
    gpsd:pROG: shmat() succeeded, segment 4390958
    gpsd:pROG: shared-segment creation succeeded,
    gpsd:INFO: stashing device tcp://192.168.3.1:6437 at slot 0
    gpsd:INFO: opening TCP feed at 192.168.3.1, port 6437.
    gpsd:ERROR: TCP device open error can't connect to host/port pair.
    gpsd:ERROR: initial GPS device tcp://192.168.3.1:6437 open failed
    gpsd:INFO: running with effective group ID 1001
    gpsd:INFO: running with effective user ID 1001
    gpsd:INFO: startup at 2016-04-28T05:42:50.000Z (1461822170)
     
    Nilan, Apr 28, 2016
    #1
    1. Advertisements

  2. Nilan

    Nuvi-Nebie Moderator

    Joined:
    Aug 16, 2015
    Messages:
    1,725
    Likes Received:
    140
    Location:
    UK
    I would contact Eric Raymond, have a look at the gpsd link HERE
     
    Nuvi-Nebie, Apr 28, 2016
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Similar Threads
Loading...