Exasperated with Magellan Content Manager

Discussion in 'Magellan GPS' started by mafinokc, Oct 13, 2012.

  1. mafinokc


    Oct 13, 2012
    Likes Received:
    We own a Magellan Maestro 4250 GPS which has not been updated in a while. I tried to do an update today with our home computer which is running Windows XP Home. The first thing I discovered when trying to log onto the Magellan site was that although we had registered our GPS when we bought it and set up an account, I had to re-register. I then downloaded the current version of Content Manager. It installed without difficulty and logged on with my account without difficulty. That was the last thing that was not difficult. I opened CM and plugged in the GPS. It took about four tries before the GPS stayed on. It then gave a message that it was plugged into the computer through the USB port and I should follow the instructions from the desktop program. It wasn’t that CM failed to recognize the unit; it didn’t do anything at all. It did nothing and it did it over and over again. I tried to set up a profile for a new device although you’d figure that a good program would have been able to sync with the online product registration. It told me to plug in the device, which WAS plugged in. I unplugged it and plugged it back in again. Then a whole lot of more nothing happened. Again and again. I tried to look at the Help instructions. The Help link turned out to be a link to your website, but I never saw and still have not seen the CM Help, because that page went into “(Not Responding)” mode. I tried again. That froze the entire browser. I tried to navigate around CM. That froze the entire computer, including WinPatrol and the Task Manager. The PC would not shut down, so I cold-restarted it. Windows hung forever. I cold-restarted it again, and Windows started normally. However, the computer was now huffing along like an old mule with heart failure. Task Manager took about half a minute to start. Task Manager Processes included one copy of Firefox and several copies of Internet Explorer running in the background which could not be terminated. Folders would not open. WinPatrol would run, but I could not open it to Active Tasks. At that point I decided to remove Content Manager. However, IObit’s Advanced System Care was also running so slowly that I could not get to Content Manager to uninstall it. I tried to do a Forced Uninstall; not even that worked. I tried using CCleaner, which opened well enough and let me try to uninstall CM; but the uninstaller DID NOT RUN. I tried again with Advanced System Care: Same thing: The uninstaller DID NOT START. I finally had to cold-shutdown the PC again and reboot it into Safe Mode. In Safe Mode, I was able to use Advanced System Care to get to the program listing and the native uninstaller actually did work that time. I rebooted into Normal Mode, and the computer is running fine again. So now, how am I to update the GPS unit? Because there is NO WAY IN HELL that I’m reinstalling Content Manager.
    mafinokc, Oct 13, 2012
Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.