Garmin eTrex 30 unbrick?

Discussion in 'Garmin GPS' started by spammi, Jan 20, 2020.

  1. spammi

    spammi

    Joined:
    Jan 20, 2020
    Messages:
    1
    Likes Received:
    0
    I hava a garmin etrex30 here. It's very strange. I cured 4 different garmin devices in the past.

    Now I have a Garmin eTrex30 and it is absolute strange. On startup it showed just the garmin logo and the small text showing etrex30, Copyright... Then it's frozen. It stucks in this state.
    I produced cure and original firmwares and installed different versions. Up to FW-Version 4.1 (I didn't try 4.2 to 4.8, the actual one is 4.9) the eTrex started. It was detected by Garmin express and I successfully installed language-files. Then I tried to install updates to 4.9. It stucks at boot process.

    So, next step. I formatted the internal storage with LinuxMint. Of course I know, this might cause problems. And: I could boot the FW 4.9. But the eTrex could'nt either find Data on the Storage nor could it write to it ("database error"). Yes, that's because I formatted it with Linux. Afterwards I formatted it with windows (not quick format). Still the same. So I used RMPrepUSB. And - it stucks again.

    So I don't know, what to do... Maybe some of the really experienced users have some advice for me :) Thanks.
     
    spammi, Jan 20, 2020
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Similar Threads
There are no similar threads yet.
Loading...