Garmin Tread issue -weather radar and alerts gone when u disabled a map

Discussion in 'Garmin GPS' started by gerard143, Jan 14, 2022.

  1. gerard143

    gerard143

    Joined:
    Jan 14, 2022
    Messages:
    2
    Likes Received:
    0
    So i bought a garmin tread to use off-road (for snowmobiling) and noticed it has weather radar, alerts, and weather forecast (when paired to garmin tread app on phone).
    Later on I noticed weather radar icon was gone, and only weather showed up.

    Their tech support suggested resetting device. So I did all that bs and set the whole thing back up again and had radar. I said oh cool. Then I disabled CN North America NT maps, so the gps doesnt try to route me on roads when I am using my GPStrailmasters third party maps on the device. Sure enough, after doing that, the weather radar and alerts disappear. Reenabled that map and they are back. Weather forecasts however always work.


    This is really annoying. Is there any kind of workaround anyone knows of. I can't keep that map on for this off-road application.

    Can anyone else verify this issue? Can you disable that CN North America map and see if you lose weather radar option like 20 seconds later. Then reenabled and see if it comes back. I am on the latest software. 7.50
     
    Last edited: Jan 14, 2022
    gerard143, Jan 14, 2022
    #1
    1. Advertisements

  2. gerard143

    Nuvi-Nebie Moderator

    Joined:
    Aug 16, 2015
    Messages:
    1,848
    Likes Received:
    150
    Location:
    UK
    Certain features are built-in to maps like zip codes / (Post Codes in the UK), if you try to use a map that does not have these features then the options are removed, I'm guessing the features that become unavailable for you are built-in to the map
     
    Nuvi-Nebie, Jan 14, 2022
    #2
    1. Advertisements

  3. gerard143

    gerard143

    Joined:
    Jan 14, 2022
    Messages:
    2
    Likes Received:
    0
    After hours of messing with it, without making any real changes, it started working again. Has to be a software bug. It has gone in and out before like this. Reported it to garmin but of course he "couldn't replicate the issue".
     
    gerard143, Jan 15, 2022
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.