magellan 3000, always "searching"

Discussion in 'Magellan GPS' started by de la Tousche, Feb 20, 2016.

  1. de la Tousche

    de la Tousche

    Joined:
    Feb 20, 2016
    Messages:
    1
    Likes Received:
    1
    Hello

    I have an old (1995) Magellan GPS 3000 which I haven't used for some time .

    It seems to be functional, but when I tried to use it recently, it didn't set up.

    I have set it up before (months ago), recently i change the batteries.

    Today it mostly sat there saying "Searching".

    No bars appears on the screen.

    When checking satellites found, it could always see severals.

    After a long period of time the screen indicates always “searching” without result of fixed point, any last fix!

    It’s impossible during the initializing to enter the date. The date prime suspect is the date.

    It’s a known issue? , and is there any way round it. How to solve it ?

    Thanks
     
    de la Tousche, Feb 20, 2016
    #1
    david thompson likes this.
    1. Advertisements

  2. de la Tousche

    Nuvi-Nebie Moderator

    Joined:
    Aug 16, 2015
    Messages:
    1,725
    Likes Received:
    140
    Location:
    UK
    Nuvi-Nebie, Feb 21, 2016
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Similar Threads
Loading...