Magellan RoadMate 7722-LM

Discussion in 'Magellan GPS' started by The-Ghost, Sep 10, 2018.

  1. The-Ghost


    Sep 10, 2018
    Likes Received:
    So I am bought a Magellan RoadMate 7722-LM and I tried
    to install their "content manager" called SmartGPS Eco

    Well I can tell you that their software isn't so smart

    I am running Windows 10 Pro 64 bit. here and 16 GB of RAM

    Intel Core i7-2600 3.40 Ghz

    So I logged into the site using my Magellan login / password
    when it redirected me to this other site as it said that I
    could use the same login / password there as well.

    So I downloaded their software closed off all my browsers and
    let it install.

    Started up my browser again and logged into the site
    only to find that the browser was not detecting the

    Now I have 3 browsers here

    Microsoft Edge 42.17134.1.0
    Firefox 62.0 (64 bit)
    Google Chrome 68.0.3440.106 (64 bit)

    So I tried Firefox and the plugin some how was not being detected
    in there. So I tried Google Chrome and nope it didn't work in there
    either. So I figured what the heck I should just try
    Microsoft Edge and the site complains then that it only supports
    Firefox or Google Chrome currently. The hell it does I just tried
    Firefox and Google Chrome and the plugin isn't recogonized there.

    When I was doing this I should say that the device was connected
    to the computer as well via the USB cable provided by

    So now I am really considering returing this thing because well it
    is useless to me without a content manager.

    So just for laughs I have a 2nd machine here running Windows 7 (64 bit)
    So I changed the GPS device over to that machine and plugged the USB
    cable into that machine and installed the SmartGPS Eco software
    again on that machine and nope doesn't work over there either on
    Windows 7 (64 bit)

    This machine is a Intel Core i5-2500 3.30 Ghz 20 GB of RAM
    on this machine running Windows 7 (64 bit)

    On this machine I have Firefox and Google Chrome

    I mean really two different machines and two different
    operating system and their POS software doesn't seem to want to run
    on either of them.

    Has anyone else actually got this new content manager to install

    I mean what the heck is wrong with Magellan?

    I am going to call support tommorow but if they can't get this
    working then it is going back!

    Now I did find some info about why Firefox may not be supporting
    it as well.

    And they list the reasons here in this post as to why
    Firefox no longer supports NPAPI plugins.

    "The regular release of Firefox 52+ only allows one plugin, which is Flash.
    The Extended Support Release (ESR) of Firefox 52 will still run Java,
    Silverlight, and vendors' proprietary plugins (as they ran in Firefox 51")

    So you would have to go all the way back to version 52 of Firefox to be able
    to actually run this and could not update anything past that according
    to Mozilla who designs Firefox.

    I mean this was phased out March 7 2017 it has been over
    a year now since this was done.

    It is currently September 10 2018 when I am writing this post.

    This was 17 months ago that the NPAPI plugins were phased out.

    This is unacceptable I mean Magellan should be updating their software
    and ensure that it works on the latest browser or write a stand
    alone content manager.

    really I have not even had this GPS a full day yet and I am already
    hating it. This is really a bad first impression with Magellan.

    Is there any work around for this or how are people updating
    their content currently if they have one of these
    Magellan RoadMate 7722-LM devices?
    The-Ghost, Sep 10, 2018
  2. The-Ghost


    Sep 10, 2018
    Likes Received:
    Ok so a bit of an update on this....

    I did find a copy of the Firefox 52.0 ESR on the Firefox

    Installed it into a seperate directory from my other Firefox version.

    Now in order to do this I had to unplug my network cable for this
    because it immediately updated to the latest ESR version which
    is not what I wanted.

    Also before you do this create a folder on your desktop and drag your
    current Firefox icon into there or it will change it when you install the
    2nd version.

    Once I got 52.0 ESR installed then I went to Tools, Options,
    Advanced, and cick on the update tab
    and then put the radio button into Never check for updates.

    I uninstalled the plugin and then reinstalled it again

    Then I went back to
    logged in and the stupid thing still wanted me to
    install the plugin and the device was plugged in as well
    via the USB cable but still was not being recognized!

    I went to tools, Add-ons and Under the plugins the plugin for
    the Magellan content manager is not even showing up there
    and this is now version 52.0 ESR Grrrr what the hell!

    I am so sick of this GPS device already!
    The-Ghost, Sep 10, 2018
  3. The-Ghost


    Sep 10, 2018
    Likes Received:
    Ok so a bit more of an update about this issue I opened up a support ticket on
    this issue and got an email back from Magellan and basically their response
    was that they currently do not have any content management software for the
    device and that there was no way for me to upload any kind of custom POIs
    into the device.

    So the Magellan RoadMate 7722-LM got returned today and then I went
    and got a nice little Garmin Drive 50-LM I went home and installed the
    Garmin Express software and it works beatifully.

    I will never buy another Magellan GPS unit ever again absolutely
    horrible company!
    The-Ghost, Sep 10, 2018
Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Similar Threads
There are no similar threads yet.