Wrong date on Etrex H

Discussion in 'Garmin GPS' started by anthony maunder, Dec 26, 2018.

  1. anthony maunder

    anthony maunder

    Joined:
    Dec 26, 2018
    Messages:
    5
    Likes Received:
    0
    My Etrex H, having worked perfectly for many years, suddenly shows a date in 1999 when switched on. Contacted Garmin EU support on this 3 times over past two months but they do not have an answer to this. Only info from them is that I am not the only person with this problem. Agree that it is really not a big problem as It only affects the track which is shown on the map after use but it would be nice to fix.
    Yes - I have checked the software and it is up to date (3.50).
     
    anthony maunder, Dec 26, 2018
    #1
    1. Advertisements

  2. anthony maunder

    Nuvi-Nebie Moderator

    Joined:
    Aug 16, 2015
    Messages:
    1,260
    Likes Received:
    112
    Location:
    UK
    This sounds like something that used to happen to early GPSs called the week rollover problem, details here :-
    https://www.gps-forums.com/threads/what-is-the-week-rollover-problem.46549/
    Where the date of the unit would jump back some 20 years because they had a 20 year 'Week Counter', however I have never seen this problem on any unit built after about 2000 and I think the Etrex H was released in about 2007.

    Even these early GPSs are usually OK once the unit gets a satellite 'fix' because the current time and date is sent to it from the satellite, however even though the current date is stored internally it is sometimes not displayed 'on-screen' correctly, this may be the case with your Etrex H,

    In the link above you will see a program supplied by Garmin to fix the Week Rollover Problem, however I am not sure it will work on the Etrex H, if you do manage to fix this problem, I would suggest always storing the unit with healthy batteries, this is normally not necessary because the unit has an internal battery to keep the clock running, however when this battery fails, it needs the main batteries to prevent the problem re-occurring
     
    Nuvi-Nebie, Dec 26, 2018
    #2
    1. Advertisements

  3. anthony maunder

    anthony maunder

    Joined:
    Dec 26, 2018
    Messages:
    5
    Likes Received:
    0
    Many thanks for this helpful reply. I managed to operate the program and it found the Etrex H, but unfortunately it did not reset the date. However you have now told me the most probable reason for the error which is that the internal battery is defective. The satnav still works and talks to my maps and to Google Earth etc - its just that the date it leaves is May 1999. If I find this too intolerable maybe I will just buy the nearest modern equivalent. Thanks again.
     
    anthony maunder, Dec 27, 2018
    #3
  4. anthony maunder

    redstag

    Joined:
    Jan 16, 2019
    Messages:
    3
    Likes Received:
    0
    i have the same problem with both my etrex h date as 30thmay 99,
     
    redstag, Jan 16, 2019
    #4
  5. anthony maunder

    anthony maunder

    Joined:
    Dec 26, 2018
    Messages:
    5
    Likes Received:
    0
    I am at 2nd June 1999 today
     
    anthony maunder, Jan 16, 2019
    #5
  6. anthony maunder

    redstag

    Joined:
    Jan 16, 2019
    Messages:
    3
    Likes Received:
    0
    I'm the 3rd june 99, i know of several others in australia that are doing the same thing ,I've put an alert out on a NZ forum and had one reply at the moment and his unit is showing the correct date , so it may look like that this problem is only in australia, so i don't think that its anything to do with the internal battery,have been in contact with garmin still waiting to hear back from them,

    i tried a trick i thought might work by wrapping the unit in silver foil and turning the unit on to stop the signal from getting into the unit and waiting for the unit to ask the question are you indoors and have you travelled hundreds of miles, and tried answering the yes or no to see if i could trick the unit into doing something ,as it asks is this the correct date, but it didn't work but i might try it again, never know

    anthony how did you get the soft ware 3.50, as mine is showing 3.0, rather interesting all of this why its happening here but not in nz, so I'm hoping i"ll get more replies from others in nz through the forum.
     
    redstag, Jan 17, 2019
    #6
  7. anthony maunder

    anthony maunder

    Joined:
    Dec 26, 2018
    Messages:
    5
    Likes Received:
    0
    It was some time ago, but as far as I can remember I connected unit to PC and used the relevant web updater. In fact it showed that it was already on 3.5. In the end I took the plunge and bought a new unit so am not using the etrex H now.
     
    anthony maunder, Jan 17, 2019
    #7
  8. anthony maunder

    mobra66

    Joined:
    Apr 30, 2019
    Messages:
    1
    Likes Received:
    1
    I had the same problem on my eTrex H, and kudos to Garmin - they have actually released a new software version 3.60 that fixes the problem! I didn't really expect that since it is an old (but good) unit.
    Check https://www8.garmin.com/support/download_details.jsp?id=3755 (using WebUpdater will also automatically detect and install the update).
     
    mobra66, Apr 30, 2019
    #8
    Worsel likes this.
  9. anthony maunder

    redstag

    Joined:
    Jan 16, 2019
    Messages:
    3
    Likes Received:
    0
    Where did you get a cable from to install the update,keen to update a new one I,Ve had in the draw for years
     
    redstag, May 1, 2019
    #9
  10. anthony maunder

    anthony maunder

    Joined:
    Dec 26, 2018
    Messages:
    5
    Likes Received:
    0
    Brilliant. Thanks. All OK now.
     
    anthony maunder, May 1, 2019
    #10
  11. anthony maunder

    Nuvi-Nebie Moderator

    Joined:
    Aug 16, 2015
    Messages:
    1,260
    Likes Received:
    112
    Location:
    UK
    Nuvi-Nebie, May 1, 2019
    #11
  12. anthony maunder

    Worsel

    Joined:
    Jun 20, 2019
    Messages:
    1
    Likes Received:
    0
    Thank You .... mobra66, Apr 30, 2019 ... I did as you said above AND .. PROBLEM SOLVED ..
    I had to reinstall Web-Updater and there were some Issues .. kept telling me to reconnect via USB .. but I persisted and eventually it uploaded the software..
    Thank You ...
     
    Worsel, Jun 20, 2019
    #12
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Similar Threads
There are no similar threads yet.
Loading...